Tuesday, November 27, 2012

Mounted and Testing Begun

The interface is complete now with all (well, most anyway) of the kinks out of it.  Here it is mounted on the wall in a utility area of the house.

I still need to install a few more sensors for the alarm system and I will soon add analog input using the SPI bus.  That worked just as expected on the breadboard.  You can see it connected in the blog post below.

There was some discussion on the forum about the serial connection for the X10 interface.  My CM11a works fine with just Tx, Rx, and GND connected.

The power supply was salvaged from a micro ATX PC case.  The 12V power supply that powers it is only 2A and I had trouble running the RasPi powered from my interface.  It worked fine on the bench with these same power supplies.  I assume that the motion detectors, which are wired to the same 12V supply are drawing too much current. This causes the ATX PS to fail to output adequate 5V current.  For the time being I have removed the power jumper (+1 for configurability) and just power it the normal way.  Once I get a beefier 12V PS, I will try powering the RasPi from the interface again.

Monday, November 5, 2012

Interface Completed

After yet another design change, I finally have the interface complete and ready to test.
Version 7 Finally Comes to Life

          ✓ Serial Port
          ✓ 8 Digital Inputs
          ✓ 4 Relay Outputs
          ✓ 2 SPI Ports
          ✓ 1 I2C Port
          ✓ Fused Power to Pi

Making the fuse involved the tiniest soldering I have ever done.  That is a surface mount poly-fuse soldered to two wires.  Once connectors are added, it is used for the jumper that connects the interface board 5V supply with the Raspberry Pi GPIO 5V pin.

The picture above shows one SPI port connected to an ADC chip on the bread board.  Once everything checks out, it will be time to mount it all.